Back to overview
Downtime
happy•groups is down
Mar 7, 2026 at 11:15am UTC
Affected services
happygroups.world
api.happygroups.world
Resolved
Mar 7, 2026 at 11:20am UTC
Another Starlink forced router update/reboot.
Affected services
Created
Mar 7, 2026 at 11:15am UTC
happy•groups down
Affected services