Back to overview
Downtime
happy•groups is down
Mar 3, 2026 at 10:00am UTC
Affected services
happygroups.world
api.happygroups.world
Resolved
Mar 3, 2026 at 10:08am UTC
Starlink router forced reboot, causing my internet to go down.
Affected services
Created
Mar 3, 2026 at 10:00am UTC
Website and API unavailable.
Affected services