Back to overview
Downtime
happy•groups website is down
Feb 24, 2026 at 9:42pm UTC
Affected services
happygroups.world
Resolved
Feb 24, 2026 at 9:47pm UTC
Server deploy caused most servers to reboot at the same time resulting in an outage.
Affected services
Created
Feb 24, 2026 at 9:42pm UTC
happy•groups website down
Affected services